Neues Thema starten

Analyse von Problemen bei DRM-Verschlüsselung

Wenn das Video schwarz bliebt und der Kunde Blackscreen issues bei Sendern mit Verschlüsselung rapportiert - der Ton aber da ist, muss sichergestellt werden, dass die STB das richtige Image hat und ein Key beim DRM-System gezogen hat. Dazu nimmt man vorzugsweise die STB midnestens 2x vom Strom. Damit werden Hard-Reboots verursacht und die STB zieht einmal die neue Firmware runter und dann den Key vom DRM-System. 


Wenn das nichts hilft, wird empfohlen wird, als erstes auf der Set-Top-Box zu prüfen, ob auch ein entsprechende Software (A) geladen wurde. Dies lässt sich aber auch ohne Kunde mit den Logfiels (B) prüfen. Sehr aufschlussreich kann auch (C) sein. 


(A) Dies kann der Kunde auch über [Menu] > [Set-Top-Box] > [Einstellungen] und unter Software-Version prüfen: 



Das Datum der Software für DRM sollte auf jedenfall älte rsein als 20160407!

Überprüfe ob die Software-Version wie folgt ist 3.4.0.160407!


(B) Alternativ kann man sich das auch in den Logfiles anschauen.


2016-04-13T00:12:32+02:00 20-3d-66-92-f1-b2 procman[492] seq=115478 msec=350 Note Firmware DBL: 5.4.3, Software: WatchAndFeel-3.5.0.151202/s08:/mnt/data/stb/SDKs/4.6.1.cornsilk.9 heads/release-3.4.0-0-g59a9c23-dirty Built: 20151202/132535 

 

Hier wird schnell sichtbar, dass der Kunde ein Release vom 20151202 geladen hat.  WatchAndFeel-3.5.0.151202

Anstatt ein Release Software: WatchAndFeel-3.4.0.160407.


(C) zur Analyse empfiehlt sich auch im Logfile-Analyzer "SecureM" einzugeben. Hierbei interessiert uns folgende Passagen, die sehr eindeutig sind. WARN: SecureMedia: bad response from SMDaemon => have no idea if registered. Not initialized - will not work! 

   

xxx line 1: DEBUG: SecureMedia: Checking registration existence locally 
xxx line 1: WARN: SecureMediaAjax: failed to parse response. Got SM image? 
xxx line 1: WARN: SecureMedia: bad response from SMDaemon => have no idea if registered. Not initialized - will not work! 

   

Update 18-04-2016: Alle STB's werden jetzt mit dem neuen Image bespielt. Sollten STB's mit älteren Images auftreten, müssen wir dieses Problem wieder unter die Lupe nehmen. 


Update 20-04-2106: Im Idealfall sehen die Logfiles wie folgt aus. 

 

xxx line 1: DEBUG: SecureMedia: Checking registration existence locally 
xxx line 1: INFO: SecureMedia: STB has registration. 
xxx line 1: DEBUG: SecureMedia: Checking registration validity from status 
xxx line 1: DEBUG: SecureMedia: Status received... 
xxx line 1: INFO: SecureMedia: ...registration is valid. 
xxx line 1: INFO: SecureMedia: registering VOD pre-playback handler 
xxx line 1: INFO: SecureMedia: registering channel change handler 
xxx Note Starting (SecureMedia SDK v2.1.0.7136) ... 
xxx main.cpp#46: Running SecureMedia service v2.1.0.7136 

 

Sobald ein Programm gewechselt wird, überprüft der Player ob die Inhalte verschlüsselt sind (oder nicht) und geht dann mit Tune is Visible auf den Bildschirm, siehe unten. 

 

xxx line 1: DEBUG: TvPlayer: playChannel RTL2HD-SecMedia 
xxx line 1: DEBUG: player: opening url: http://re02-vod01.zhjo01.watchandfeel.ch:8000/at/472afb82659126ac02430f9b0e27c7f9/1461085461/play?id=ch1002sm_tcp 
xxx Note [SecureMedia ECM] session 1 opening ECM encrypted LiveTV 
xxx Note [SecureMedia ECM] session 1 Found pid 101 in PMT 
xxx Note [SecureMedia ECM] session 1 Found pid 103 in PMT 
xxx Note [SecureMedia ECM] session 1 Found pid 104 in PMT 
xxx Note [SecureMedia ECM] session 1 Found CA system: id 0x4AF5 
xxx Note [SecureMedia ECM] session 1 Found program level SecureMedia descriptor with ECM pid 0x666(1638) 
xxx Note [SecureMedia ECM] session 1 Update cipher settings: pid 101, type 3, mode 1, residue 2 
xxx Note [SecureMedia ECM] session 1 Update cipher settings: pid 103, type 3, mode 1, residue 2 
xxx Note [SecureMedia ECM] session 1 Update cipher settings: pid 104, type 3, mode 1, residue 2 
xxx Note Video: Out of sync 
xxx Trace {event} TUNE: Video is visible 

 

Anmelden oder Registrieren um einen Kommentar zu veröffentlichen